Page 3 of 3 FirstFirst 123
Results 21 to 25 of 25

Thread: canopy problem

  1. #21
    Senior Member wizrod's Avatar
    Join Date
    Jul 2007
    Location
    Rickmansworth, Hertfordshire
    Posts
    158
    Well....I've just spent the last hour & a half looking.. .poking at things...trying things out....but not getting any progress.

    First off, both valves appear to work - or at I can hear them both clicking when I apply 12v to each lead - so my initial hypothesis that Valve A sticks open, may not be correct.

    I've also confirmed that the roof powers both up and down.

    From the tecnical drawing in the mod manual, I think the relief valves are behind the 2 plastic covers on the opposite side of the pump casing to the exit ports. they were too tight o undo, so I left well alone. TBH, I'm loath to tinker too much incase I make the situation worse.

    I've been in touch with Islandman, who has kindly agreed to sell me one of his spare pumps. I think I'll postpone any further investigation until I've got a properly working pump installed - at whcch time I may attempt some dis-assembly of the current pump.

    Many thanks for all your input...I'll update this thread with my progress.

    P.
    cheers

    Paul

  2. #22
    I would adjust the relief valve, if everything works then that might just be the problem. It just needs a little adjustment and then test and a little more and test. New one might be the same ie needing adjusted.

  3. #23
    Senior Member MicksRedNova's Avatar
    Join Date
    Jul 2007
    Location
    Winscombe, North Somerset, England
    Posts
    2,267
    Quote Originally Posted by Gmacz View Post
    I would adjust the relief valve, if everything works then that might just be the problem. It just needs a little adjustment and then test and a little more and test. New one might be the same ie needing adjusted.
    If its like the new modern pumps the relief valves are 'sealed' to prevent users fiddling. 210 bar is about 3000 psi so I would not suggest adjusting unless you have a pressure gauge attached.

    Mick
    Club Nova Member (F-036)

    MicksRedNova2 may take as long as the original!!

  4. #24
    According to the info by islandman, pump has fully adjustable relief valves. Maybe previous owner adjusted them as it has never sealed the canopy according to wizrod.

  5. #25
    Senior Member wizrod's Avatar
    Join Date
    Jul 2007
    Location
    Rickmansworth, Hertfordshire
    Posts
    158
    Well...I have a list of things to address on the car this weekend...so I'll have opportunity to dig deeper into these then...weather permitting!!
    cheers

    Paul

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •