Page 15 of 15 FirstFirst ... 5131415
Results 141 to 146 of 146

Thread: Scottish Nova - time for a rebuild!

  1. #141
    Senior Member BlueNova's Avatar
    Join Date
    Apr 2015
    Location
    St Andrews, Scotland
    Posts
    411
    Quote Originally Posted by madscientist View Post

    Although painfully slow (usual stuff, work, family, life....), I am going in the right direction with my Nova I think. ..... Colin
    Sounds like you're doing just fine Colin. Looking forward to seeing the photos!

    With my chassis needing so much attention I'll probably not be too ambitious with suspension, etc. My main priority is to get her back on the road and then 'tinker' with such things.

    Cheers, Alistair

  2. #142
    ***Euro-Nova Supporter***
    Join Date
    Jul 2012
    Location
    London
    Posts
    377
    Blog Entries
    1
    Hi Alistair,
    Nice update, looking at those pics, talk about a ground-up rebuild, wow.
    Good that you have discovered the corrosion issues now, when you are in a position to correct them.
    Keep up the good work - and the updates coming.
    Steve

  3. #143
    Senior Member BlueNova's Avatar
    Join Date
    Apr 2015
    Location
    St Andrews, Scotland
    Posts
    411
    Quote Originally Posted by steve View Post
    Hi Alistair,
    Nice update, looking at those pics, talk about a ground-up rebuild, wow.
    Good that you have discovered the corrosion issues now, when you are in a position to correct them.
    Keep up the good work - and the updates coming.
    Steve
    Thanks for that Steve .... here's a wee update!

    I spent some more time in the garage today. I was aware that the body was getting covered in fine dust as a result of all my cutting and grinding, so in order to avoid the risk of it becoming rust covered if it gets wet, I cleaned the body and covered it in poly sheets. I should have done this when I started on the chassis, but hopefully it'll be fine. Despite the odd chip or small scrape, the paint's still in remarkably good condition .... the body's the best part of my Nova!

    Anyway, I started cutting away the rusty sections of the frame head and am happy that what's left is good solid steel. Going down this route (rather than a complete new frame head) means that I'm dealing with thicker steel than the modern replacements. Still got some cleaning up of the rest of the tunnel and the rear torsion arms, etc, but it shouldn't be too long now till I'm posting photos of patch welds on the frame head and new floor pans, etc.

    Cheers all, Alistair

    Body cleaned and wrapped.jpg Front RHS of tunnel.jpg Rot cut out of front face.jpg Underside of Frame Head.jpg

  4. #144
    Senior Member
    Join Date
    Mar 2009
    Location
    East Riding
    Posts
    752
    Nice work, lucky you can save most of the frame head. Remember when you weld in the patches that the frame head is set up to produce the caster angle so don't leave any weld on the forward face.

    Dirk

  5. #145
    Senior Member BlueNova's Avatar
    Join Date
    Apr 2015
    Location
    St Andrews, Scotland
    Posts
    411
    Quote Originally Posted by Dirk View Post
    Nice work, lucky you can save most of the frame head. Remember when you weld in the patches that the frame head is set up to produce the caster angle so don't leave any weld on the forward face.

    Dirk
    Cheers Dirk. Will do Alistair

  6. #146
    Senior Member BlueNova's Avatar
    Join Date
    Apr 2015
    Location
    St Andrews, Scotland
    Posts
    411
    Hi folks,

    Thought it might be worth mentioning this .... I believe the 'rust worm' problem I'm currently dealing with in the front of my chassis was caused by the lack of a front frame cover plate. I was blissfully unaware that it was missing till I stripped the car, but the fact that the front frame bottom plate and parts of the frame head itself were rotten means that water must have been getting inside the main tunnel. Thankfully the majority of the underside of the main tunnel is still solid, but most of the rot is at the front where the cover plate was missing.

    Go and check you've got one securely in place!

    Alistair

    Missing front frame cover plate.jpg
    Attached Images Attached Images
    Last edited by BlueNova; 09-10-2017 at 12:22 AM. Reason: Another photo attached

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •